Status
Get in touch
Back
Resolved
App is unavailable
Started 19 May at 08:43am CEST.
Affected services
Notifications service
21risk.com
Created
We had a brief outage caused by rotating secrets
Posted 19 May at 08:43am CEST.