Get in touch
Back
Resolved

Database Maintenance

Completed 7 Jun at 01:00am CEST.

Notifications service 21risk.com
Completed

Maintenance ended

Posted 7 Jun at 01:00am CEST.
Started

We are upgrading the 21RISK database, and the app will be unavailable in the meantime. We expect the app to be down betweeen UTC 10:00-23:00

Posted 6 Jun at 12:00pm CEST.